http://lists.nongnu.org/archive/html/phpcompta-contrib/2012-05/msg00019.html

Version > 6.9 Bonjour,

Beaucoup de personnes nous ont demandé de pouvoir utiliser un hébergement mutualisé avec postgresql.

Les 2 problèmes qui se posaient étaient :

1) une seule base de données disponible avec un nom fixé par l'hébergeur
2) les paramètrages dans les .htaccess ne fonctionnaient pas.

Pour résoudre ces 2 problèmes, nous avons du modifié PhpCompta, PhpCompta fonctionne sur serveur mutualisé à partir de la version 6.6

Etape pour l'installer:

Remarque importante : Menu Administration

pour hébergement mutualisé ovh pro en mars 2013 : avec le manager v3,

a) outil : hébergement / gestion SQL / nouvelle base PostgreSQL : permet la création de la base

b) outil : hébergement / gestion SQL / nouvelle base PostgreSQL : permet l'affectation du mot de passe

c) outil : hébergement / gestion SQL / phpPgAdmin: permet de se connecter à la base

d) attention, les opérations ne sont pas instantanées. Lorsque je me connectais avec “phpPgAdmin”, j'avais un écran presque vide avec juste le message “Serveurs : ! aucun objet trouvé !”. Au bout de 2h, la base est apparue…

Décompressez l'un des modèles proposés, décompressez-le et restaurer ce fichier de backup avec l'outil de votre hébergeur.

Si ce n'est pas possible vous pouvez charger et executer l'un des fichiers de noalyss/contrib/mono-dossier

Décompressez l'archive dans le répertoire de votre site web

chez ovh pro mutualisé : avec un outil comme putty, affecter récursivement les permissions 604 (+Add X to directory )

Utilisateur : utilisateur pouvant se connecter sur postgresql donc celui que vous avez utilisé pour PhpPgAdmin mot de passe :de l'utilisateur port : en haut dans phpPgAdmin vous voyez le port, c'est celui-là qu'il faut donner

*) Sur ovh mutualisé pro apparait le message d'erreur : “magic_quotes_gpc a une mauvaise valeur !”. La fonctionnalité globale “magic-quote” devient deprecated en version 5.3 et absente en version 5.4 ( [[http://www.php.net/manual/en/security.magicquotes.whynot.php]] ) Une solution est de forcer la version PHP 5.4 en créant un fichier .htaccess contenant :

SetEnv PHP_VER 5_4

se connecter (phpcompta/phpcompta) et ajouter des périodes dans Paramètre PERIODE pour correspondre à l'année courante.

Aller dans préférence, changer le mot de passe + période par défaut

Tous les plugins sont supposés fonctionner.

Si vous essayez, merci de faire un renvoi d'informations (réussi, bug, idée, …)

Cordialement

Dany De Bontridder

  • installation/installation_sur_serveur_mutualise.txt
  • Dernière modification: 2018/04/03 21:46
  • par dany